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Classe : Mastére professionnel DWFE
Matiére : Développement WEB c6té serveur et frameworks
Enseignant : Slim NAMOUCHI

Configuration de PHPStorm avec Symfony 3.2 et création du 1°"
projet

Introduction

Symfony est un framework MVC qui va vous permettre de réaliser des sites complexes rapidement,
mais de fagon structurée et avec un code clair et maintenable. Par contre nous avons dit que
Codelgniter permet de développer des sites simples.

Objectifs
Le but de cette séance est la mise en place de 1’environnement de Symfony3 et la création d’un premier
projet avec 1’éditeur PHPStorm.

Recommandations

e Utiliser une version de PHP supérieur ou égale 8 PHP 5.5.X

e Utiliser la version 3.2 de Symfony

Variable d’environnement
Renseigner la variable d’environnement « php » dans le path si ceci n’est pas déja fait :

1. Aller sur le répertoire Wamp et copier I’emplacement de votre interpréteur php (exemple :
a. C:\wamp\bin\php\php5.x)

2. Aller dans Panneau de configuration -> Systéme -> Paramétres systéme avancés ->
a. Variables d’environnement.

configuration

| MNom de l'ordinateur I Matériel |

) Eriphé P P .
® Gestionnaire de périphériques Paramétres systéme avancés | Protection du systéme | Utilisation 3 distance |
@ Paramétres d'utilisation 3
distance Vous devez ouvrir une session d'administrateur pour effectuer la plupart de

ces modifications

'SJ Protection du systéme
Performances

| P &t Sté 2
ﬁ SR Tysieme avances I Effets visuels, planification du processeur, utiisation de la mémaire et

mémoire virtuele
Paramétres...

Frofil des utilisateurs

Paramétres du Bureau liés 3 votre ouverture de session

Démarrage et récupération
Informations de démamage du systéme, de défaillance du systéme et de

débogage

[ Variables d'environnement ... ]
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3. Sélectionner la variable Path -> modifier -> dans « valeur de la variable » atteindre la fin du

textbox et rajouter un point-virgule puis copier I’adresse de votre interpréteur php

(C:\wamp\bin\php\php5.x)

Propriétés systéme 23_
Nom de I'ordinateur | Matériel
Variables d'environnement (-
| |
Modifier la variable systéme ot

Mom de |a variable :

Valeur de la variable :

Path

hongk: C:\wamp'biniphp'phps. 5. 12;@: \Prog

[

QK

]l Annuler |

Variables systéme

Variable Valeur i

NUMBER_OF_P... 4

ot Wiodowe NT

Path C:\ProgramData\Orade\Java\javapath;... I

FRTTICAT SO CAE DA T ol |u,.vD::,.uD|:,.H,....
|Nouvelle... | | Modifier. .. | | Supprimer |

| OK || Annuler |

4. Tester sous I’application CMD la commande PHP et voir si elle est prise en charge (taper

par exemple taper php —v).

BN Administrateur : C:\Windows\system32\cmd.ex-

Microsoft Windows [verzion 6.1.76611
Copyright (c> 208? Microsoft Corporation. Tous droits préservés.

C:sUserssStorm>php —v

PHP 5.5.12 {cli> {built: Apr 38 2814 11:28:58>

Copyright (c> 1997-2814 The PHP Group

Zend Engine v2. 5.8, Copyright (c> 1998-2814 Zend Technologies

with ¥debug v2.2.5, Copyright {c) 2802-2014, by Derick Rethans

C:sUsers\Storm>

Installer et activer PHPStorm

Apres I’installation de PHPStorm, pour I’activer cliquer sur :

1) Serveur de licence (Licence server).
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2) Enter cette adresse du serveur http://jetbrains.tencent.click

3) Cliquer sur Activer (Activate).

Cannot obtain ticket from http://172.245.22.235:11

Activate license with:

(71 JetBrains Account () Activation code @) License server

License server address: Mare info...

|htt|:|:ﬂjeﬂ3rains.tencent.didt.| |

Discover server ]

Les étapes de création d’un projet Symfony avec PHPStorm

Deux méthodes sont possibles pour créer un projet Symfony avec PHPStorm. La premiere méthode est
recommandée.

lere méthode

1. Lancer I'IDE PHPStorm, cliquer ensuite sur Configure et sélectionner Plugins.


http://jetbrains.tencent.click/
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E Welcome to PhpStol

PhpStorm

Version 2016.3.1

3% Create New Project
= Open
% Create Mew Project from Existing Files

¥ Check out from Version Control

@) Events v % Configure ~
Settings
Plugins
Irnport Settings
Export Settings
Settings Repository...
Check for Update
Manage License...

Institut Supérieur des Arts Mt

2. Saisir « Symfony Pluginy» dans la zone de recherche. Si aucun résultat n’apparait, cliquer sur
Search in repositories.
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(@ symfony Plugin ) Shows | All plugins ~ |

Check or uncheck a plugin to enable or disable it.

Sort by: name ¥

ugins found. Search in repusitaries

Institut Supérieur des Arts Multimédias

InstallJetBrains plugin... | | Browse repositorics... | | Instal plugin from disk...

3. Sélectionner « Symfony Pluginx» puis cliquer sur Install.

@' Symfony Plugin @ (%] [ Category: All ']

Drupal Symfony Bridge
FRAMEWORK INTEGRATION

PHP Annatations 4
FRAMEWORK INTEGRATION

PHP Toolbox
FRAMEWORK INTEGRATION

SensiolabsInsight
INSPECTION

Shopware Plugin

Sort by: name ¥

13 556
& months ago
88 440 Hriririok
2 months ago
22681 ik
5 months ago

19 357

one month ago

HTTP Proxy Settings... J I Manage repositories... ]

Updated 13/11/2016 w0.12.131

Symfony [T Documentation | Doc on GitHub | Donate
Install

® Activate per praject in “File == Seftings -= Languages &
Framework -= PHP -= Symfony” or use auto configuration
notification

® (Optional) Configure a default project connection in "Remote

Hosts Access / Remote Hosts™ to enable support for remate

duplicate classes "Seltings -= Project -= Directories™

& (Optional) Install PHP Annotations

@ (Optional) Install PHP Toolbox

@ (Optional) To support XLIFF translations add ™ xIf" / ™ xliff" to
XML "Editor” -= "File Types”

Features: Version
0il supports Symfony 2 and 3
Dependency Injection Container

@ References for senvices in Containerinterface:get()

@ Detect Containerinterface::get() result type

@ References for senices, tags, events, methods, ... inside
yaml, xml and php

® Indexer to provide live editing without a compiled container

@ Tagged class indexer

2016-2017
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4. Une fois I’installation s’est terminée, cliquer sur « Restart PhpStorm ».

@ soveisie. I =
@' Syrfony Plugin @l (3 | Category: All =

Sort by: name ¥ FRAMEWORK INTEGRATION

| Drupal Symfony Bridge 13 556
FRAMEWORK INTEGRATIOM 6 months ago
PHP Annotations 488 440 ey
FRAMEWORK INTEGRATION 2 months ago

PHP Toolbox 22681 Yrdrdriedr Updated 13/11/2016 v0.12.131

FRARACAARE TRITES R A TIARD - JE—

5. Maintenant nous pouvons créer un projet Symfony avec la version désirée. Il faut donc choisir
la bonne localisation du projet (c:\wamp\www\nomProjet ou c:\xampp\htdocs\ nomProjet), la
version de symfony et I’interpréteur PHP.

@ PHP Empty Project New project

PHP spedcific
@ App Engine Project I__ocatlon:l Chowampiowww\DWFE_SMEF I

= Composer Project
@ Drupal Module
14 Joomla! Integration

Symfony Version

Installable‘u’ersions||3.2.ﬂ (latest) n l Reload ‘

@ WordPress Plugin [] Deme Application

Web The Symfony Demo Application is a reference application created to
1Y Angular CLI show how to develop Symfony applications following the
¥ Angularis recommended best practices.

Foundation Settings

B HTMLS Boilerplate Path to PHP executable: || Chwamphbin\phpi\php5.512\php.exe d:\
(2 Mod e.js Express App
4 React App

6. En cas de I’apparition de cette erreur : curl: (60) SSL certificate : unable to get local issuer
certificate.
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Event Log

ok 08/12/2016
05:29 Syrmfony-Installer

. cURL error G0: 551 certificate problemn: unable to get local issuer certific

E"j ate

— [GuzzleHttp\Ring\Exception\RingException]

. cURL error G0: 551 certificate problemn: unable to get local issuer certific
ate
new <directory> [<wversion=]

it
i

a) |l faut télécharger le fichier cacert.pem via cet URL https://curl.haxx.se/ca/cacert.pem
b) Ajouter le lien vers ce fichier dans le fichier php.ini comme suit :
Ouvrir le fichier php.ini ensuite décommenter le paramétre curl.cainfo et modifier sa valeur :
curl.cainfo ="C:/wamp /cacert.pem"
c) Redémarrer WAMP ou XAMPP et PHPStorm.

Liste des répertoires
Vous devez avoir I’arborescence suivante du projet créé :

& DWFE_SMF - [C:\wamp\www\DWFE_SMF] - PhpStorm 201¢

File Edit VYiew Mavigate Code Refactor Run Tools

DWFE_SMF |
[ Project - & = | %1+

¥ DWEFE_SMF C:wamp'wwew\DWFE_SMF

app

bin

Erc

tests

war

vendor

¥ ¥ v¥ Yy yyvyy

web
= .gitignore
5oy COMNpPOSErjson

composerlock

«» phpunitxml.dist
o README.md
» il External Libraries
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Le répertoire /app

Ce dossier contient I’ensemble des éléments compilés de votre application, que ce soit le code PHP
généré par Symfony ou le code compilé de Twig. Les fichiers de configurations globaux de
I’application sont dans ce dossier (Exemple config BDD).

Aussi, on trouve dans ce dossier un sous-dossier qui s’appelle Resources qui contiendra toutes les
Templates, toutes les vues, ¢’est-a-dire tout le HTML de votre projet, alors on n’aura plus de Twig dans
les sources de notre application. (une bonne pratique).

http://symfony.com/doc/current/best practices/templates.html

Twig : Twig est le nouveau moteur de template créé par SensiolL.ab, I’éditeur de Symfony. Ce moteur
est conceptuellement trés proche du moteur de Django.

Le répertoire /bin

Ce répertoire contient tous les exécutable « console » dont nous allons nous servir pendant le
développement. Par exécutable, nous voulons dire des commandes PHP.

Le répertoire /src

C'est ici que I'on mettra le code source. Dans ce répertoire, nous organiserons notre code en bundles. Ce
répertoire n'est pas vide : il contient en effet quelques fichiers exemples, fournis par Symfony.

Le répertoire /tests

Les fichiers de tests unitaires et fonctionnels (Referez-vous a la présentation de Narimane pour plus
d’informations sur les tests d’un site web).

Le répertoire /var

Il contient tout ce que Symfony va écrire durant son process : les logs, le cache, et d'autres fichiers
nécessaires a son bon fonctionnement. Nous n'écrirons jamais dedans nous-mémes.

Le répertoire /vendor

Ce répertoire contient toutes les bibliothéques externes a notre application. Vous pouvez parcourir ce
répertoire ; vous y trouverez des bibliothéques comme Doctrine, Twig, SwiftMailer, etc.

Le répertoire /web
Ce répertoire contient tous les fichiers destinés a vos visiteurs : images, fichiers CSS et JavaScript, etc:

e Le fichier .htaccess,

e Le fichier app.php (un seul doit étre présent en production). C’est le fichier source de
Symfony. C’est le point d’entrée global de 1’application, 1’équivalent du index.html pour
apache,

e Le fichier app_dev.php, équivalent de app.php réservé aux développements,

e [’ensemble des ressources externes ( js / css / images ).

A retenir

Retenez donc que nous passerons la plupart de notre temps dans le répertoire /src, a travailler sur nos
bundles. On touchera également pas mal au répertoire /app pour configurer notre application. Et lorsque
nous installerons des bundles téléchargés, nous le ferons dans le répertoire /vendor.

Enfin, pour tester si vous avez bien installé et créé un projet Symfony 3.2, taper ’'URL suivante
http://localhost/dwfe_smf/web



http://symfony.com/doc/current/best_practices/templates.html
https://sensiolabs.com/fr
http://en.wikipedia.org/wiki/Django_%28web_framework%29
http://localhost/dwfe_smf/web
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o
& CcC 0O |® localhost/dwfe_smf/web/ =] ‘ﬁ'| &k € @ 9 0 ¢

HH Applications W@ Webmail - OVH 85 Sci-Hub: removing bz @ Creative - Page 2 of ¢ D Développons en Java 6 LiDAR Magazine - Tz D The PHD Movie 2! n Git for Scientists: A T

Welcome to

Symfony 3.2.0

Your application is now ready. You can start working on it at:
V € : \wamp \vmw\DWFE_SMF\

What's next?

0 Read the documentation to learn
How to create your first page in Symfony

2éme méthode
1. Créer un nouveau projet sous PHPStorm. Il faut choisir Composer Project comme type de
projet (File->New Project->Composer Project). Le projet doit étre situé sous c:\wamp\www ou
c¢:\xamp\htdocs.
2. Apres avoir choisi le type du projet il faut saisir les différentes propriétés pour I’installation de
la version symfony 3.2
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@ PHP Empty Project  Neaw project
PHP specific

Composer Project I omposer.phar

14 Jeomla! Integration O Use existing composer.phar ||j
® WordPress Plugin © Download composer.phar from getcomposer.org I
Web
1Y Angular CLT
Package
¥ Angular)s
@ Foundation Filter packages: @' symfony/fr

}s Ann Ennine Proiecd Location: | ChwarmnpwwwhDWFE_SMF_2 ”j

[l HTMLS Boilerplate
(2 Nodejs Express App
& React App

b React Native T T
£ symfony
u Twitter Bootstrap
¥ Web Starter Kit

Available packages Description

brazilianfriendsofsymfony/frete-braspress-bun The "Symfony Standard Edition™ distribution
brazilianfriendsofsymfony/frete-bundle :

G- I =

PHP interpreter: | B PHP 5.5 (5.5.12) HD

Command line parameters: | -f --No-progress | =

1. En choisissant cette propriété le composer.phar sera installé automatiquement.
Composer, qu'est-ce que c'est ? Un gestionnaire de dépendances

Composer est un outil pour gérer les dépendances en PHP. Les dépendances, dans un projet, ce sont
toutes les bibliothéques dont votre projet dépend pour fonctionner. Par exemple, votre projet utilise la
bibliothéque SwiftMailer pour envoyer des e-mails, il « dépend » donc de SwiftMailer. Autrement dit,
SwiftMailer est une dépendance dans votre projet.

Composer a donc pour objectif de vous aider a gérer toutes vos dépendances. En effet, il y a plusieurs
problématiques lorsqu'on utilise des bibliothéques externes :

e Ces bibliotheques sont mises a jour. Il vous faut donc les mettre a jour une a une pour vous
assurer de corriger les bogues de chacune d'entre elles.

e Ces bibliotheques peuvent elles-mémes dépendre d'autres bibliotheques. En effet, si une de
vos bibliotheques dépend d'autres bibliotheques, cela vous oblige a gérer I'ensemble de ces
dépendances (installation, mises a jour, etc.).

e Ces bhibliotheques ont chacune leur paramétres d'autoload, et vous devez gérer leur autoload
pour chacune d'entre elles.

Composer va nous aider dans chacune de ces taches.

10

Version to irftall: | 3.2.x-dev n H
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Apreés avoir saisi ces différents parametres il faut cliquer sur create.

Vous devez avoir I’arborescence suivante du projet créé :

File Edit View Navigate Code Refactor Run Tools VC5 Windo

[ DWFE_SMF_2 )
B Project R
¥ [0 DWFE_SMF_2 C:\wamp\www\DWFE_SMF _2
b [0 app
= [0 bin
B sre
b [0 tests
B L var
b [0 vendor
b 10 web
] .gitignore

F | .
1500 COMPOSEr.json

Qmaoeer o

»> E compaser.phar

o phpunitxml.dist
o README.md
v Il External Libraries
= 1 PHP Runtime

Au niveau de votre navigateur

@ Welcome! X

€ C 11 [0 localhost/cfe smi 2/web/ Wh|k € @ @6 0 A& ©
13 Applications W Webrail - GVH 55 Sci-Hub: removing b @b Creative - Page 20 ¢ [3 Développons en Jave @ LIDAR Magazine - T=' [7 The PHD Movie 2! [l Git for Scientists: AT

Welcome to

Symfony 3.2.0

Your application is now ready. You can start working on it at:
v C: \wamp \www\DWFE_SMF_2\

What's next?

@ Read the documentation to learn
How to create your first page in Symfony

11
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Ajout des commandes de Composer et Symfony

Dans cette partie nous allons voir comment utiliser la console de PHPStorm que nous allons s’en servir

dans nos projets Symfony.

Symfony integre un utilitaire qui permet de taper des lignes de commande que nous allons utiliser dans
tous les ateliers Symfony. Dans PHPStorm il faut configurer Commande Line Tools Console (qui
s’affiche en appuyant sur Ctrl-Shift-X) a travers du quel nous allons exécuter les commandes Symfony.

1. Pour configurer cette console accéder a File->Settings->Tools->Commande Line Tool

Plugins
1l Version Control
Directories
Build, Execution, Deployment
Languages & Frameworks
Tools

Web Browsers.

File Watchers

External Tools

Tool Support

Diff & Merge
Docker Machine

Remote SSH External Tools
Server Certificates

Settings Repository
Startup Tasks

Tasks

Vagrant

XPath Viewer

I Tools ; Command Line Tool Support = For current project

| Enabled | Alias | Tool Path Type Es
Nothing to sho
Show tool type
Show console in:
O popup © tool window

Console enc

2. Cliquer sur + puis choisir Symfony au lieu de Composer.

(B Setting: oy pr——

@ )

caitor

Plugins.
Version Control
Directories
Build, Execution, Deployment
Languages & Frameworks
Tools
‘Web Browsers
File Watchers
External Tools

Terminal
Database

S5H Terminal
Diagrams:

DIiff & Merge

Docker Machine
Remote S5H External Tools

Server Certificates

Settings Repository
Startup Tasks
Tasks
Vagrant
XPath Viewer

Tools > Command Line Tool Support 2 For current project

| Enabled | Alias | Tool Path Type

Nothing to shou

==

Command Line Tools

Choosetool: | Composer

Composer
Drush
Symfony

Visibility:

[Tool based on Symfony Console
[we-cLl
[Zend Framework 1 Tool

|Zend Framewaork 2 Tool
Custom tool

Show tool type
Show console in:

(O popup @ tool window

Console encoding: | UTF-8 =

12
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a) Il faut indiquer ensuite ou se situe le terminal de commande fournit par symfony (dans notre

cas C:\wamp\www\DWFE_SMF_2\bin\console) ainsi que I’interpréteur PHP.

Q@

) Tools > C Line Tool Support & For current project

v

v

v

4

v canor | Enabled | Alias | Tool Path Type

Plugins

Version Control

Directories

Build, Execution, Deployment

Languages & Frameworks

Tools Mothing to show
‘Web Browsers
File Watchers
External Tools

Path to Symfony: | Ywamplwaww\DWFE_SMF_24bin\console ‘D

Terminal
» Database Path to PHP executable: |C:\wamp\bin\php\phpSﬁll\php.ae n D
S5H Terminal

Symfony component version: | 3.5.* v
Command Line Tool Support

- Diff 8 Merge

Docker Machine
Remote 55H External Tools

Server Certificates S

Settings Repository
Fedi Tt Show console in:
b Tasks O popup o tool window
Vagrant
Console encoding: | UTF-8 ~
XPath Viewer

3.

b) En fin, cliquer sur OK, Apply puis OK. Et maintenant les commandes Symfony sont bien

installées.

Installer Composer.phar via https://getcomposer.org/download . En accédant a cette page vous
devez suivre la figure ci-dessous et cliquer sur la version 1.2.1 pour le téléchargement de la

derniére version du composer.phar. Il faut placer ce fichier sous c:\wamp

php composer-setup.php --version=1.8.8-alpha8

Preview / Snapshot Releases

By default the installer and  composer self-update will download stable versions only If you would like to
help test pre-release versions you can use the  --preview flag on either installer or self-update. Faor snapshot
builds which are done from the latest Composer commit, you can use the  --snapshot  flag.

Manual Download
If you prefer to download the phar manually, here are the available versions:

Latest Snapshot

1.2 4 (2016-12-06)
123 (2016-12-01)
1.2.2(2016-11-03)
1.2.1(2016-09-12)
1.2.0(2016-07-18)
1.2.0-RC (2016-07-04)

13
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4. Cliquer sur + pour ajouter un outil composer
a) Ensuite il faut indiquer I’interpréteur PHP (qui se trouve sous c:\xamp\php\php.exe ou
c:\wamp\bin\php\php5.6.25\php.exe)
b) Ensuite, il faut mettre dans Path to composer le chemin vers le composer.phar
(c:\wamp\composer.phar).

(B seting: — -

e ————- lij

IR |

Q@

) Tools > Command Line Tool Support = For current project

—
Plugins
» Version Control

i pr—

Directories
¥ Build, Execution, Deployment
» Languages & Frameworks
7 Tools
Web Browsers
File Watchers
External Tooels
Terminal
¥ Database
55H Terminal
Command Line Tool Support
Diagrams
» Diff & Merge
Docker Machine
Remote 55H External Tools
Server Certificates
Settings Repository
Startup Tasks
¥ Tasks
Vagrant
XPath Viewer

| Enabled | Alias | Tool Path | Type \[E
s C\wamphbin\php\php5.5.12\php.ex... Symfony

© composer.phar or php script

p\bin\php'phps.5.12\php.exe 'D

Path to composer.phar or composer | Cwamp\composer.phar -

Path to PHP [c

() composer executable

Path to executable: ‘U

Show teol type
Show console in:

O popup  © tool window

Console encoding:

[ o

2016-2017

c) En fin, cliquer sur OK. Dans ce cas il rajoutera des commandes qu’on utilisera via la console.

& settings | ot
@ ) Tools ; Command Line Tool Support = For current project
o | Enabled | Alias | Tool Path | Type I+
Plugins s C\wamp\bin\php\php5.5.12\php.ex... Symfeny
I Version Control ¢ C\wamp\bin\php\php5.5.12\php.ex... Composer

Directories
» Build, Execution, Deployment
» Languages & Frameworks
¥ Tools
Web Browsers
File Watchers

External Tools

Terminal
» Database
55H Terminal

Command Line Tool Support

Diagrams
Diff & Merge
Docker Machine

v

Remote S5H External Tools
Server Certificates

Settings Repository

Startup Tasks

b Tasks
Vagrant
XPath Viewer

Show teel type

Show console in:

(O popup @ tool window

Console encoding:

14
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Sachez que Symfony respecte bien entendu cette architecture MVC. Je ne vais pas entrer dans ses détails,
car nous avons vu avec Codelgniter, comment le patron MVC fonctionne.

Afin de bien visualiser tous les acteurs que nous avons vus jusgqu'a présent, voici un schéma du parcours

complet d'une requéte dans Symfony :

Requéte
GET /platform

Controleur frontal

URL : iplatform

h 4

Kernel Symfony2 Routeur
L
Contrdleur -
OCPlatformBundle: Advert
h 4 Demande : liste des
annonces -
L Maodéle
i Annonce
N Donne la liste des
annonces
Contraleur
OCPlatform: Advert
Donne la liste des
annonces o
» Vue
g ListeAnnonces
Donne la page
HTML
Pape HTML

A

En le parcourant avec des mots, voici ce que cela donne :

15
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Le visiteur demande la page /platform ;

Le contrdleur frontal recoit la requéte, charge le Kernel et la lui transmet ;

Le Kernel demande au Routeur quel contréleur exécuter pour I'URL /platform. Ce Routeur est
un composant Symfony qui fait la correspondance entre URL et contréleurs. Le Routeur fait
donc son travail, et dit au Kernel qu'il faut exécuter le contréleur OCPlatform:Advert ;

Le Kernel exécute donc ce controleur. Le contrdleur demande au modéle Annonce la liste des
annonces, puis la donne a la vue ListeAnnonces pour qu'elle construise la page HTML et la lui
retourne. Une fois cela fini, le contréleur envoie au visiteur la page HTML compléte.
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